Both Windows and Macintosh computers can view videos on Mediasite. The requirements for each operating system are different:

Windows

  • Windows 7, Windows Vista, or Windows XP
  • Microsoft Internet Explorer 6.0 SP1 or later, Firefox 2.0 or later, or Google Chrome 1.0 (Chrome is only supported on Mediasite version 5.0.3 and later).
  • Windows Media Player 9 or later.
  • For Firefox and Chrome playback, Silverlight 1.0 or later (viewers are prompted to install this when attempting to view a presentation).
  • If using a Silverlight player instead of a Classic player, Silverlight 3.0 or later is required.
  • Broadband Internet connection (256 Kbps or more)

Mac

  • Mac OS X 10.4.8 or later.
  • Safari 2.0.4 or later or Firefox 2.0 or later.
  • Silverlight 1.0 or later (viewers are prompted to install this when attempting to view a presentation).
  • If using a Silverlight player instead of a Classic player, Silverlight 3.0 or later is required.  Silverlight 5.0 is required for Mediasite 6.0.2 or later.
  • Broadband Internet connection (256 Kbps or more)

Note: Newer versions of Silverlight cannot be installed on PowerPC Macs.  Silverlight 1.0 was the only version to be supported on the PowerPC platform.